Resolved
The issue was resolved after the mitigation was applied.
Monitoring
A few users saw bursts of 503 errors on Git operations due to a rollout on code.storage. A short-term fix was implemented, and a longer-term fix will roll out shortly. We did not expect more errors and monitored the situation closely.