·
Resolved latency spike around p95 read operations.
Resolved
Investigating
Increased latency in p95 read for AWS eu-central-1